Installer un iPad à bord

Toutes les questions techniques autour de l'électronique.

Modérateur : modérateurs

Règles du forum
bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Ven Mars 03, 2017 21:45

yahyah a écrit :1 semaine sans de tes nouvelles Bobmorane ! J'espère que tu as reçu ton kit pour démonter le poste.


Héhé ... Ouaip, j'ai (enfin) reçu les outils en début de semaine.

Image

Pas trop le temps demain et météo pourri :( mais Dimanche ça a l'air bon.

Au passage j'ai commandé un second module CAN (MCP2515) pour faire le bridge et une carte de dev pour le Raspberry http://www.ebay.fr/itm/DIY-Prototyping-Hat-Shield-Hole-Plate-Kit-for-Raspberry-Pi-2-Model-B-A-B-AS-/292034300748?hash=item43fe99cb4c:g:UncAAOSwB-1Yq7B- histoire de pouvoir mettre les cartes CAN de façon moins artisanale qu'avec les fils volants.

Pour le démontage je vais suivre ça : https://www.linkedin.com/pulse/how-upgrade-2014-2015-nissan-x-trail-radio-15-steps-alice-jing

Je vous tiens au courant ;)

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Ven Mars 03, 2017 22:03

J'ai quand même quelques interrogations ...
Il semble que ce model de poste (LCN2) n'ai pas de code à saisir si le 12V est retiré. Perso je n'ai pas reçu de code de Nissan, et vous ?
J'espère aussi pouvoir démonter facilement les pins des connecteurs pour pouvoir faire tous les tests sans prendre aucun risque (par exemple injecter un signal vidéo en même temps que celui du 4cam). J'ai pas envie de couper les fils non plus :)
Bref, on avisera !

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Sam Mars 04, 2017 20:32

En préparant mon test de demain je réalise quelque chose qui est semble totalement bloquant :(
Je me connecte au Raspberry via le wifi pour émettre l'écran de mon téléphone et l'afficher.
Seulement, si je suis en Wifi, je ne suis pas en 3G. Donc pas de Waze :(

Mon téléphone (Samsung Note 4) dispose d'une option "booster", qui permet d'avoir Wifi et 3G simultanement, mais
cela ne fonctionne que pour les téléchargements :(

Je suppose que le mirrorlink tient compte de cela. Je vais chercher.

Pfff, ça remet en cause totalement mon projet :(

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Sam Mars 04, 2017 20:48

En fait, il faut que je fasse l'inverse. Plutôt que de créer un point d'accès Wifi sur le Raspberry, il faut que je partage ma connexion 3G de mon tel via Wifi, et c'est le Raspberry qui se connectera sur mon téléphone. Je garderais alors ma connexion 3G et waze fonctionnera.
Plus compliqué en terme de configuration réseau, car rien n'est disponible coté Android (pas de conf possible de l'attribution de l'IP par exemple).

Je ne sais pas aussi si mon soft de mirroring pourra "voir" le raspberry pour envoyer la copie de l'écran ...

Bon, une lueur d'espoir ...
C'est le grand 8 émotionnel :)

yahyah
Messages : 44
Inscription : Lun Jan 16, 2017 21:43

Re: Installer un iPad à bord

Messagepar yahyah » Sam Mars 04, 2017 22:08

yes, Bobmorane, bien vu le point d'accès wifi sur ton téléphone.

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Dim Mars 05, 2017 11:03

yahyah a écrit :yes, Bobmorane, bien vu le point d'accès wifi sur ton téléphone.


Et en plus ça marche tbd4
Au passage, le raspberry gagne un accès à internet. Intéressant ...

Bon, démontage cet aprèm :)

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Dim Mars 05, 2017 16:07

Bon, après démontage et remontage, résultats mitigées :(

- Démontage assez simple MAIS ATTENTION aux vis. Malgré mes précautions, une des vis difficilement accessible (celle en haut à droite du poste) à glissée dans le tableau de bord et à dégringolée au bas. Impossible d'y accéder sans tout démonter :evil: !!! J'ai du en bricoler une plus ou moins identique. J'espère que celle tombée ne va vibrer et faire du bruit, voir pire.
Image
Image
Image
Image

- Impossible de débrancher les pins des connecteurs. A partir de la, l'exploration devient très compliquée. Le connecteur semble se démonter. Je n'ai pas testé plus loin, de peur de le casser ...
Image
Image


- J'ai débranché le connecteur cam4. L'affichage 4cam ne fonctionne alors plus. Je pense que le passage à la vue camera suppose un flux vidéo.
Image

- J'ai rebranché et connecté la sortie vidéo du Raspberry SUR la sortie 4cam. Comme je m'y attendais, ca pertube l'affichage du 4cam, mais rien de vraiment concluant.

- J'ai écouté (et enregistré) le port CAN (du 4cam) (même config que celui de l'OBDII). J'ai observé des trames liées aux boutons du poste et du volant. Pour l'instant, ma première analyse est liée a l'appuie et au lâché des touches :

4f9 82 CC 00 02 FF FF 00 => Appuie
4f9 82 CC 00 22 FF FF 00 => Laché

Mais comme on le constate, pas de distinction de touche. Il doit y avoir une autre trame indiquant le numéro de la touche.

Conclusions :
- Je vais acheter les connecteurs pour pouvoir intervenir sur les fils sans appréhension de tout flinguer.
- Ca repousse à qq semaines
- Je vais poursuivre l'analyse des trames

Je vous sollicite pour financer l'achat du connecteur https://fr.aliexpress.com/item/Lossless-Audio-And-Video-Input-Harness-For-Toyota-Crown-Reiz-Corolla-RAV4/32650794034.html?isOrigTitle=true. Qu'en pensez vous ?

Avatar de l’utilisateur
jejeadsl
Messages : 33
Inscription : Dim Mars 06, 2016 9:29
Localisation : Rezé (44)

Re: Installer un iPad à bord

Messagepar jejeadsl » Dim Mars 05, 2017 16:31

bobmorane a écrit :Bon, après démontage et remontage, résultats mitigées :(

- Démontage assez simple MAIS ATTENTION aux vis. Malgré mes précautions, une des vis difficilement accessible (celle en haut à droite du poste) à glissée dans le tableau de bord et à dégringolée au bas. Impossible d'y accéder sans tout démonter :evil: !!! J'ai du en bricoler une plus ou moins identique. J'espère que celle tombée ne va vibrer et faire du bruit, voir pire.
Image
Image
Image
Image

- Impossible de débrancher les pins des connecteurs. A partir de la, l'exploration devient très compliquée. Le connecteur semble se démonter. Je n'ai pas testé plus loin, de peur de le casser ...
Image
Image


- J'ai débranché le connecteur cam4. L'affichage 4cam ne fonctionne alors plus. Je pense que le passage à la vue camera suppose un flux vidéo.
Image

- J'ai rebranché et connecté la sortie vidéo du Raspberry SUR la sortie 4cam. Comme je m'y attendais, ca pertube l'affichage du 4cam, mais rien de vraiment concluant.

- J'ai écouté (et enregistré) le port CAN (du 4cam) (même config que celui de l'OBDII). J'ai observé des trames liées aux boutons du poste et du volant. Pour l'instant, ma première analyse est liée a l'appuie et au lâché des touches :

4f9 82 CC 00 02 FF FF 00 => Appuie
4f9 82 CC 00 22 FF FF 00 => Laché

Mais comme on le constate, pas de distinction de touche. Il doit y avoir une autre trame indiquant le numéro de la touche.

Conclusions :
- Je vais acheter les connecteurs pour pouvoir intervenir sur les fils sans appréhension de tout flinguer.
- Ca repousse à qq semaines
- Je vais poursuivre l'analyse des trames

Je vous sollicite pour financer l'achat du connecteur https://fr.aliexpress.com/item/Lossless-Audio-And-Video-Input-Harness-For-Toyota-Crown-Reiz-Corolla-RAV4/32650794034.html?isOrigTitle=true. Qu'en pensez vous ?


Salut Bobmorane,

as-tu un compte paypal pour que je te fasse un virement de 30 euros, si cela suffit ?
Si oui, envoi moi stp un msg en privé avec ton adresse email.
Merci et bravo pour tes investigations

Pour info, le thailandais que j'avais contacter me propose de m'envoyer tous le necessaire pour faire du mirrorlink sur notre nissan connect. Interface bus can + boitier miracast 5G pour 290 dollars.

@+
QASHQAI II 1,6l DCI 130ch, Tekna + Pack Crossover, Xtronic, noir métallisé, jantes 19" et toit panoramique - 08/2016

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Dim Mars 05, 2017 19:10

Voila le panier Aliexpress :
Image

Total : 23,72€

Autant je n'ai pas trop de doute sur les connecteurs séparés à qq euros, autant celui à 18€ est plus hasardeux. Je n'ai rien trouvé de plus approchant et surtout moins cher.
Merci beaucoup pour ta proposition jejeadsl. J'attends d'autre manifestations (?) et on partage les frais (via paypal).

Pour l'offre thaï, ça me parait quand même un peu cher, mais sans doute mieux intégré.
Pour ma part, à ce tarif, je prendrais carrément un poste 2DIN Android, peut être plus cher mais plus polyvalent et aussi bien intégré.

De mon coté, ce qui me motive s'est aussi de le faire soit même à un cout "raz des pâquerettes" ;)


yahyah
Messages : 44
Inscription : Lun Jan 16, 2017 21:43

Re: Installer un iPad à bord

Messagepar yahyah » Dim Mars 05, 2017 20:07

yep moi aussi je peux participer via paypal

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Mar Mars 07, 2017 13:12

Messieurs,

Nous sommes donc trois pour partager les frais.
Je vous propose donc de couper la poire en 3. J'arrondie la somme totale à 45 euros pour couvrir les frais Paypal et autre achats (carte acquisition vidéo par exemple). Ce qui fait 15€ chacun, ce qui est raisonnable.

Afin d'être clair, de ne laisser aucun doute, et d'éviter tous litige :
Il s'agit de payer en commun l'achat de composants pour le projet de connexion d'un téléphone (aujourd'hui uniquement Android, mais ca pourrait évoluer avec l'iPhone) au poste Nissan Connect 3 (LCN2) via un Raspberry Pi, l'entrée Vidéo 4cam et un bus CAN. L'idée est d'afficher l'écran du téléphone sur l'écran du poste en appuyant simplement sur un des boutons du poste.
Ces composants sont achetés (par moi-même) pour que je réalise un premier prototype. Ces composants me restent acquis quelque soit l'issue du projet. Je ferais le maximum pour atteindre notre objectif, mais je ne garanti aucun résultat d'aucune sorte. Il n'y aura aucun remboursement d'aucune sorte.

J'en profite pour faire un récapitulatif du coût du projet :
- Un Raspberry Pi 3 : Autour des 50€
- Deux cartes MCP2515 + carte support : environ 8€ . A noter que ca nécessite de jouer du fer à souder. Pour éviter cela il est possible d'acquérir une carte toute faite (ici http://www.sg-electronic-systems.com/ecommerce/en/canberry/12-canberry-isolated-v21.html): 40€ (a valider)
- Carte acquisition vidéo : entre 5 et 15 euros selon le modèle.
- Connecteurs poste : 23€ (pas obligatoire mais FORTEMENT conseillé)
- Connexion diverse (cables vidéo) : quelques euros.
- Boitier : a votre convenance
Total : Entre 100€ et 150€ suivant les options prisent.

Si vous êtes partant je vous communique mon adresse Paypal en MP. A noter que je pourrais faire, uniquement à ceux ayant participé aux achats, une copie de ma carte SD du Raspberry, ce qui évitera toutes les manips de configuration (a condition aussi de m'envoyer une carte SD vierge et une enveloppe de retour affranchie).

Go ?

yahyah
Messages : 44
Inscription : Lun Jan 16, 2017 21:43

Re: Installer un iPad à bord

Messagepar yahyah » Mar Mars 07, 2017 13:42

Go pour moi, c'est bien 15 euros chacun ? J'attends le MP

Avatar de l’utilisateur
jejeadsl
Messages : 33
Inscription : Dim Mars 06, 2016 9:29
Localisation : Rezé (44)

Re: Installer un iPad à bord

Messagepar jejeadsl » Mar Mars 07, 2017 14:04

Idem pour moi. en attente du MP, pour le virement paypal.
QASHQAI II 1,6l DCI 130ch, Tekna + Pack Crossover, Xtronic, noir métallisé, jantes 19" et toit panoramique - 08/2016

bobmorane
Messages : 173
Inscription : Mer Nov 16, 2016 20:30

Re: Installer un iPad à bord

Messagepar bobmorane » Mar Mars 07, 2017 21:23

Merci à vous deux !

Je viens de commander les cables.

Suivant cet article ici http://raspberry-at-home.com/video-grabber-for-raspberry-pi/ j'ai aussi commandé ca : http://www.ebay.fr/itm/252116384664

Ya plus qu'a :)


Revenir vers « Electronique, audio & navigation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 18 invités